Sublab sampler broken after updating to 1.1.5

Hi guys,

So I updated my Sublab to 1.1.5 and 2 things happened when I did that;

  1. Any sample based 808 sounds have a very distorted broken sound to them. I noticed this as I went trough some of my old projects and suddenly the 808 sounded like a distorted mess. My favourite preset Signature 1 is unusable now and any other sample based sound as well. Synth based 808 sounds work fine.

  2. The sounds that I had marked “favourite” all reset and I had to go trough the whole sample library again to mark them.

Anyone else experience similar issues? Should I revert back to 1.1.3?

I’m using FL Studio 20.8 on Mac Big Sur 11.5.2.

1 Like

Hi @WackoB,

Let me check into this and see if something is up with 11.5.2

Do you have an M1 processor?

Best regards,
Gavin.

Macbook Pro 2019 15,4" with intel i7

I tried uninstalling and reinstalling 1.1.5 Sublab but it didn’t fix the issue, sample based sounds still have a distorted sound / crackle.

Looks like I’m reverting back to 1.1.3. Any way I can get my license transferred from Pluginboutique to FAW so I can reset the activations by myself?

Thanks, Wacko.

Hey @WackoB,

@Julia on support can have a look for you, just sent over an email asking her to transfer your activation code from Plugin Boutique over to Future Audio Workshop. Its Friday afternoon here, so I’d say it will be Monday before she can have a look.

Also, if you have time and are able, can you do a short screen recording or audio recording of the crackle that you’re experiencing? That would help a lot in pin-pointing the problem.

Thanks!
Gavin.

Hey @Gavin_FAW

The forum didn’t allow video upload so I had to use an external site.

As you can see the crackling sound only happens with sample based presets like Signature 1 and Signature 2, on a synth based preset like Smoke this doesn’t occur.

Sincerely, Wacko

EDIT; Also tried VST instead of VST3 and the same problem is present.

I just downloaded the new version as well and it has completely changed all my sessions. Nothing on the plug in sound the same. All my Stared favourites are gone. It’s also crashing new sessions if I try to open SubLab. I hope there’s a fix for this. I’m running logic pro x on Catalina.

Thanks so much

Ok, let me look into this…

Thanks,
Gavin.

First thing @Dax, can you confirm that you have the latest version installed?

The latest version is 1.1.5 (R436) built on 7th Aug 2021

Also @Dax, are you using your own presets in these project or are you using the included factory packs?

Yeah,
I kind of had the same problem. I bought the full bundle for sublab and updated and did not have any sounds. I have tried rescanning the folder dragging and dropping to no avail.

I’m looking into it right now guys. We obviously did beta testing and it passed ok, but sometimes certain scenarios don’t show up until we release the version.

Thanks for you patience and I’ll go through everything here and get back if I find the issue.

In the meantime it would be great if you can list your operating system, the exact version of SubLab you have (using the about page, which you visit by clicking “sublab” up in the top left hand corner)

Thanks,
Gavin.

@BandoBob, @Dax,

I’ve spent the last couple of hours verifying the sounds and it seems that everything is ok in the audio engine.

That however doesn’t mean you’re not having any issues guys.
@Dax, do you have a crash report from Logic? This would help a lot as we can see where things are going wrong. To find the crash report for Logic, just type “Console” in finder and click the icon. Then you’ll see something like in the image below. Click on the latest Logic crash you see and copy and paste the text into a text file and send it as a private message here…

Can you PM me a direct link to the video? Also can you show the sample panel page open so I can see what is happening there. Thanks for help and also the patience on this…

Hey @Gavin_FAW I really appreciate that I have the crash report. Seems like SubLab works in sessions that had it opened before the update. It only crashes if I try to open a new instrument of Sublab. I also confirmed I’m running the latest version, For some reason I can’t send you a private message. It won’t let me?

Ok, I see what your issue is now. It is when you instantiate the plugin in Logic that it crashes. If you can send me the crash report to gavin.burke@futureaudioworkshop.com I’ll have a look and see if I can figure out what is up.

Thanks,
Gavin.

Hi there - are all factory presets missing? Or just the presets from the pack bundle?

If you’re just missing the presets from the pack bundle, please reinstall them like this.

I am also getting really bad distortion in the sampler. It is definitely broken in 1.1.5

M1 Mac Mini…Tested in FL Studio, Cubase, and Live 10/11

Ok, its an M1 Mac Mini.

We can do a M1 specific build and send that over for testing to you. I feel that the sampler is working fine, but you’re experiencing some kind of overloading of the processor while it is playing.

I am currently on holiday until the end of the month, but will have a look at the M1 build during this time and then send it over once I’m back fully on 1st of October. How does that sound?

Gavin.