SubLab is not listed in Logic Pro X (AU)


I am new here, and I just bought SubLab. It works nicely on the standalone, though I need to install the non-M1 Version for it to work. The M1 Native Version doesn’t launch at all.

My Mac is the 2020 Macbook Pro M1, and currently running on macOS 13 Ventura Beta. Everything works, except that the plugin doesn’t appear on my Logic Pro X instrument list. It does show up in the Plugin Manager, and it shows a successfully validated status.

I tried reinstalling SubLab, reinstalling Logic Pro, deleting Logic Cache, rescan, and everything I have in mind and what I found, but nothing works.

Any help or insights would be appreciated as I wanted to use this amazing plugin!
Thank you,


Hey @tyranix,

I would have thought that deleting the Logic cache and restarting your computer would have worked.

What might be an idea is to delete the SubLab.component from “/Library/Audio/Plug Ins/Components” and then re-run the M1 installer.

Let me know how it goes!

Hi @Gavin_FAW!

Thank you for the reply. I don’t know what is wrong but somehow I cannot get the SubLab M1 to work on my M1 device. I do, however, try the non-M1 Version and it runs fine (the standalone).

Tried the steps you mentioned, but sadly not working. This time, it crashed validation on the Logic Pro X (where the non-M1 version will successfully validate) and doesn’t appear on the instrument list.

Looking forward to from you!

Ok, I think what is up is something to do with Ventura. We’re working on this at the moment and will have an update asap :+1:

Thank you for the reply!

Please get back as soon as any fix is applied!
Would love to use this plugin because it is SUPER awesome!

Its a super high priority @tyranix as Ventura is coming out very soon :+1:

Very well, then!
Let me know if you guys need something to assist you regarding the problem!


1 Like

Hey Michael,

SubLab should work in Ventura if you install the regular macOS installer and run Rosetta!

Take care,


Thank you for the reply! I already did that, and unfortunately, it still hasn’t shown up yet on my Logic Pro. :frowning:
Please do update if you have any other idea to try!


Anyone has updates regarding the issue? I still cannot access sublab right now in my Logic Pro X.
Looking forward for an update.


Hey @tyranix

We’re releasing the Ventura beta later today so keep an eye here on the forum for when that is ready for download :+1:


Oh Good Lord!

Finally, after downloading the latest beta (1.1.9), it works like a charm!
Thank you for all the help!



Great news that it is work @tyranix!

Good day, where might a find a link to the new beta (1.1.9) I have exactly the same issues as you. thanks

Hey Neville,

Here are the mac link:
:round_pushpin: SubLab macOS 1.1.9 Beta 1 M1
:round_pushpin: SubLab macOS 1.1.9 Beta 1 32/64 (Install this version for AAX support)

Take care,

Run the installer with your DAW closed, after the install is complete reboot your computer. Then try to launch SubLab again. If you still don’t see it listed in Logic try this:

  1. In the Finder, press Option and choose Go > Library.

  2. In the Finder window, go to Library/Caches/AudioUnitCache.

  3. Move the files from AudioUnitCache folder to the Desktop.

  4. Restart the computer, then open Logic Pro. All installed Audio Units plug-ins will be rescanned.

Hey Julia,

Thank youso much, it worked perfectly upon re-instalation of the new installer.

Thank you so much.


Great news @Neville!

So I am having very similar issues. Purchased it from Plugin Boutique half a year ago. I’ve tried deleting it and reinstalling using the M1 installer. Downloaded the 1.1.9 version. It always crashes validation in the Plugin Manager and I can’t figure out what else to do. Any suggestions? Thank you.

Hey there :wave:

Could you launch the SubLab standalone app please? Click the “sublab” logo in the top left corner of the GUI, take a screenshot of this page and send it to us please. Cover your activation code or just DM the photo to me.