[Update] SubLab XL 1.0.2 Beta - Ventura and more

Hey everyone,

Just uploaded a macOS beta of version 1.0.2

  • This first beta version includes a fix SubLab XL not activating on Ventura.
  • SubLab XL installer should no longer overwrite your favorite presets and settings.
  • We’ve added a setting which allows you to turn on/off if xSub should track pitch bend and glide.
  • Fixed a bug in 1.0.1 where zero crossing on samples didn’t work correctly.
  • Fixed an issue where the synth engine’s scope sometimes displayed weird waves if you kept playing notes while quickly changing presets.

:point_right: SubLab XL macOS 1.0.2 Beta4

:point_right: SubLab XL Windows 1.0.2 Beta4

Thanks for the help as always,


great to have this working. and good timing: the ventura RC dropped today (the 18th); the official release is the 24th.

am exploring XL now. am getting some audio glitches with it (will reboot, try again later), but mostly… am impressed. and lots to explore.

how do i get my older sublab library into XL? is there an easy step? thanks

EDIT: seems ok after rebooting, will keep you posted.

Are you still experiencing the glitches @fisherking ? If you are, then can you pm me your system setup? You can get them by going to the “settings” page, then “about” and click the “copy tech specs to clipboard”

@fisherking…to import the packs, open the browser and then click the import icon…see the image below.


ha! just messaged you as your reply here came in! no glitches this morning, so the reboot probably mattered. & thanks for import tip.

XL is NICE, and will put it work on every new project. will post here if anything. :+1:

EDIT: um… WHERE are the sublab packs (mac OS)?

EDIT2: ok, exported all the packs from sublab. will importing (for example) Analog Machines overwrite the pack already IN XL? how do i add my previous patches without losing anything?

sorry lots of questions


Glad you’re liking XL, thanks for the patience :raised_hands:

sublab XL (standalone) just crashed while scrolling thru factory presets (i NEVER use it standalone, was just exploring it today). i saved the crashlog if you want it…


crash log would be great, please send it over to my email address ( I’ve sent you a pm with my direct address :+1: )

1 Like

Thx so much…its running on Ventura RC.


Nice one! Really glad that we got the release working for you all by Ventura launch! :champagne:

1 Like

Running on Ventura in Cubase under Rosetta 2 for the moment! After this update I don’t have problems to login anymore! Thank you

I’ve tried both of the betas you’ve posted and still stuck at the “launch” button in ableton (latest) and mac ventura 13. What’s next? I just bought this and would love to use it.

Could you please try activating the standalone app?

I did so just now per your request and I received the same result.

Hi @Icongreen,

Are you trying to activate SubLab or SubLab XL?