[Update] 1.1.7 update thread (latest beta 2 macOS M1 & Win release 3/2/22)

Hey everyone,

We’ve released another beta version of SubLab.

Please find the links below:
:point_right: macOS 1.1.7 Beta 4
:point_right: Windows 1.1.7 Beta 4

In this version we have implement a new more stable id for your computer. This ID should not change when you update your OS etc, therefore resulting in your slots staying cleared.

We’re also looking at clearing all existing activation slots for all customers.

  1. Fixed ID so it should not change between operating system re-installs.

  2. Fix standalone plugin so that it saves the midi inputs, audio buffer and selected audio cards between launches.

  3. Add the ability to play your computers keys to trigger notes ( standalone version ).

  4. Added feature to set the bpm in the standalone version. (new in beta 2) .

  5. Added feature to set the bend amount (new in beta 2)

  6. AAX is still not loading for some users. We’re not sure why this is the case.

  7. Updated installer to retain the settings file between installs.

  8. Set the range of the pitch bend to 24 Semitones

  9. Fix the missing desktop icon on Windows.

  10. Allowed for “hard reset” of the phase when both “reset phase on new note” and “reset ADSR level on new note” are both set to “Yes”. For more info see the thread here

Thats about it for the moment, if you find any bugs please post below and we’ll have a look!

Thanks,
Gavin.

1 Like

Hmmm I downloaded and installed and I guess it didn’t do any of the things I was hoping you would have incorporated after the last beta.

  1. it once again ignored my saved zoom setting and defaulted back to 100%.

  2. it ignored the FL sequence mode.

  3. my request for the ability to transpose octaves was not done.

  4. I haven’t tested this but we learned last time that on windows it would overwrite presets and thus removing which patches you are favourited… I am not about to install this on windows (I have so far only installed it on mac) to find out that this too was not addressed.

To say disappointed would be an understatement.

rsp

@zvenx

We’ll add 1 and 2 in the next update.

3 will have to wait until 1.1.8 as we want to get out version updates in small increments as people are having issues with activation.

On 4, is it working on macOS?

Thanks,
Gavin.

  1. is indeed still working on mac, but it was in 1.1.6 too, it is on pc that it was broken.
    rsp

I’m checking here, we have a flag in the installer maker that when set should mean that files are not overwritten when you upgrade from a lower to a higher version. I’m double checking here…appreciate the help it is exactly why we send out betas in order to catch these things :+1:

Thanks!
Gavin.

Well I understand that, but if I reported it as unfixed in 1.1.6 it wouldn’t be magically fixed unless you did something different now.
Is this flag new?

rsp

And no I tried it, it isn’t fixed.
What is the point of me reporting bugs and you ignoring them.
You are just wasting my time in reporting bugs.

Btw this is a bug I first reported a year or two ago, whenever it was I bought SubLab

rsp

1 Like

In the past minutes I’ve checked the windows installer and it wasn’t working. I’ve set a new flag and tested and it works and rebuilt and re-uploaded the installer for windows.

If you favorite a preset and then run the installer it should not overwrite the favorites. I’ve tested here.

Thanks for the help @zvenx!

That’s great.
Any reasons why the links to the installers are not in the thread itself? Have to go look for the email now with the links.
rsp

I can confirm indeed it is finally fixed.

thanks
rsp

1 Like

Big issue with samples. The app (plugin and standalone) does not see any samples. There is a relocate button in this case but it is unuseful as the name of the sample used in the preset is not displayed.

Moreover, the relocate feature does not work at all. I tried to relocated a sample from DECAP 808 pack, because there is only one within this pack, and it fails to relocate.
image

Even worst ! I imported the sample in the patch and saved it. It looked ok. But when going back to this patch, the sample was away again :frowning: :frowning: :frowning:
I also tried to re-scan the pack folder but without success.
The same when you create a new preset. You can’t no longer see the list of the samples available.
image

I m going to go back to previous 1.1.6 version hoping this will solve the problem. I m stuck will all my tracks using Sublab that is almost every.

Please be reactive because it s not a small bug but something terribly blocking.
Regards

Going back to 1.1.6, the issue is still there :frowning:
My config = Ableton Live 11 Suite, Windows 10 pro, Core i7 11th gen, 32Go ram, 1To SSD

Hello. I’ve tested the beta version and I have some suggestions for the next updates.

  1. Please let us choose what we want to install in the installer (ex: AAX, VST2, VST3, AU, Standalone)
  2. when you click command+I to see info about the sublab file it says version 1.0.0 and this is a pain when using programs like MacUpdater because the app will see always sublab as an outdated app.
  3. Will be great if we have an option to speed up / down a sample.

Thank you

Big relief & happy end. I ended up fully uninstalling and re-installing SubLab… and it works back again. I had to re-install all my sub packs and my personal patchs I d backed up before the operation.
All sample are there and visible.

If someone experience the same, I think uninstall/re-install is the workaround.

2 Likes

I noticed there is still a kind of glitchy noise when opening the SubLab UI. As you could see in the video i attached here, I guess this is due to high resource demand at the moment the UI is displayed.
Watch & listen this here => Testing SubLab 1.1.7 beta - YouTube

Just want to add, this does not happen because of a weak configuration. Everything’s running on a core i7 11th gen + 32Go ram + a strong GPU = NVIDIA GeForce RTX 3050 Ti

Hey, you mentioned in the FR thread that customizable pitchbend would be in this version. I’m not seeing it anywhere.

Hey @ChristopheLambert

I had a look at the video and I notice the glitches. I think what is happening there is a momentary glitch as the interface is constructed.

Have you tried increasing your buffer size? Say to something like 1024 and then retesting.

Thanks,
Gavin.

@everyone,

Just putting a new build together, we’ll add a setting for the bpm along with pitch bend amount.

Thanks,
Gavin.

1 Like

Hey Gavin. I tried with different buffer sizes. My first test was with 512 samples, then 1024 and 2048. But I still have those glitches with bigger buffer size. However I noticed the sound is a bit different as long as you change the setting. I use an audio interface (Audient iD MkII) which has a pretty good ASIO driver and honestly I never came accross a similar issue with other plugins even those with complex UIs… I guess that the audio process has not enough time to fullfill the audio buffer when opening the UI. Anyway increasing the buffer is just a workaround because it also increases the latency. I guess the actual solution should be to improve the UI display. Maybe a GPL option for those having a config that can enable such a technology ? I don’t know :frowning: