[Update] SubLab XL 1.0.2 Beta - Ventura and more

Glad you’re liking XL, thanks for the patience :raised_hands:

sublab XL (standalone) just crashed while scrolling thru factory presets (i NEVER use it standalone, was just exploring it today). i saved the crashlog if you want it…

2 Likes

crash log would be great, please send it over to my email address ( I’ve sent you a pm with my direct address :+1: )

1 Like

Thx so much…its running on Ventura RC.

2 Likes

Nice one! Really glad that we got the release working for you all by Ventura launch! :champagne:

1 Like

Running on Ventura in Cubase under Rosetta 2 for the moment! After this update I don’t have problems to login anymore! Thank you

I’ve tried both of the betas you’ve posted and still stuck at the “launch” button in ableton (latest) and mac ventura 13. What’s next? I just bought this and would love to use it.

Could you please try activating the standalone app?

I did so just now per your request and I received the same result.

Hi @Icongreen,

Are you trying to activate SubLab or SubLab XL?

Thanks,
Gavin.

I already purchased sublab XL and it was working fine until this error started happening about a week or two ago. Unfortunately while i was in the middle of three projects that I was using it on.

By the way, finally fixed my problem with logic not booting (unrelated) and was able to get Sublab XL to go passed the “launch” screen. That narrows it down to an Ableton thing. I also tried the .AU (figuring it worked in logic so…) but still hangs at the launch screen in Live.

@icongreen, can you share the fix in case other people run into it?

Thanks,
Gavin.

apologies if i was unclear in my reply.
I was having a problem with your app in albeton so I went to try it in Logic, unfortunately my copy of logic was not booting up. I thought it was possibly related to your software, but after doing Apples insanely long (and only) suggestion of removing all 200+ of my plugins and add them back “one at a time” booting up logic each time, and closing when it was able to boot up. Fortunately that world but the offending plugin was not yours. When launched sublab xl in Logic it did the same thing as it’s doing in Albeton which is get caught on the “launch” button after asking me to log in. So far it’s been a week and I’m not able to re-create a sound i was using in sublab anywhere else so I’m really stuck. Could you please help me get this resolved? After reading quite a few posts it seems like I’m not the only one with this issue

Gavin, my bad. I did get it to work after logic booted, however the projects I’m working on are on Ableton. I misspoke in my last email - just double checked. Still cannot get it to work in ableton.

Hi there :wave:

Sounds like you’re getting stuck on the login screen, right? Could you try launching the standalone app and logging in there?

Let me know if that works or not!

Julia

Hi there. Sublab XL won’t activate when I put in my loggin… Any work arounds?

@DJLMNOP that looks like you have managed to activate ok, but SubLab XL hasn’t been able to create the unlocked file on disk.

What macOS are you running and have you tried the standalone version in /Applications/SubLabXL.app to activate?

Thanks!
Gavin.