Sublab shows error when looking for VST/VST3 plugin and crashes Fl Studio

I have looked up and down this page and found a few others who have posted about this problem however reading the threads didn’t find me any solutions. I have deleted all sublab files in my MacBook Pro (M1 processor) numerous times and tried re-installing everything and it still says error when searching for new plugins by sublabs VST/VST3 options (searching in FL Studio). I also use Pro Tools and I have no problem opening up and using sublab in that DAW. My only problems are in Fl Studio. Everything is up to date with the latest software.

I am trying my best to stay cool about the situation, however I have emailed support about the problems and 4 days later still no reply. I was having issues with sublab for a bit in protools and got and email back from support after about a week then when I responded to the email I was left hanging and never heard from support again and it took weeks to solve the issue.

I love using sublab in Pro Tools and I cannot wait to be able to use it in FL Studio as well, however this issues is very aggravating since it only installs the AU version of the plugin successfully in FL and if you try and open it just crashes your session and deletes it. Yes it even deleted my saved sessions after trying to find a way to open the plugin.

Please respond and help and don’t leave me hanging again. I would love to use the plugin. Its amazing when it works how it should.

Hey @brizzy,

We’ve checked here using a non M1 macbook and SubLab is loading fine in FL Studio. So my feeling is that the issue is on M1 Macbooks in FL Studio only.

We’re going working on an M1 build starting on Monday next week. Once it is ready I will post here and send you the download link.

1 Like

Perfect, thank you for the response & possible solution. Hope to hear from the team soon!