SUBLAB Making Ableton crash immediately

Sublab worked fine for a few weeks and now anytime I launch it, Ableton crashes, I basically can’t use it. its making my whole computer seize up all of a sudden. I am running the latest version of Ableton. Any ideas?

Hey @Josh,

Can you let me know the follow:

  1. What OS are you running

  2. Has anything changed recently on you computer? ( OS updated, updated Ableton, new sound card etc.)

  3. When you say launch, do you mean you are opening an existing Live project that uses SubLab or that you launch Live and when you go to add it on an instrument track it crashes?

  4. Have you tried VST, VST3, and if macOS the Audio Unit version of SubLab? And if you have do all three have the same issue?

Please answer the above as a comment here and I’ll have a better idea of what is going on and how to help out :slight_smile:


Hi Gavin,

I’m running the latest version of ableton.
My OS is Mojave 10.14.6
I haven’t added anything to my computer at all.
Previous projects, new projects, as soon as I add sub lab ableton freezes or completely crashes. I have tried all vsts and audio units.

Ok Josh, leave it with me and I’ll have a look, we have a similar macOS setup here.

Also, what type of Mac hardware have you got?


imac late 2015

Hey Josh & Gavin.
Im having the same issue with sub lab on ableton as well.
Everything else on ableton works fine, but as soon as I launch the sub lab plug in it freezes a few seconds in…or it freezes if I press a few keys on my midi keyboard…causes my entire laptop to freeze

Using ableton suit with the latest updates to mac os mojave

@SunliteSoundz, what version of Live are you using?


Hi Gavin. I am using Ableton Live Suit version 10.1.13

Ok, thanks for the info @SunliteSoundz.

Can you do a small test for me when you have a chance? I’ve linked to a document below, can you follow only the last step " Disable openGL" and see if it allows you to launch?


Good afternoon Gavin.
Thank you so much for reaching back out to me, numerous times, and making sure we can resolve this issue that I am having. I truly appreciate it.

So…I saw the document that you linked with the instructions…the only thing is that I am running a Mac OS and I don’t know how to access that file / text file at the last step…if maybe you can advise where this file would be on my mac?

Thank you so much, once again.

Hey @SunliteSoundz,

If you open the folder on your macOS drive ‘/Library/Application Support/FAW/SubLab’ you’ll find the settings file that is mentioned in the help page step.

Let me know how it goes!

Hello again Gavin.
I was looking into the “open GL” fix you had provided me…and there is another issue I am having with Sublab.
I have tried to install this on different computers…however any and every time I install Sub Lab on my MacBook…I can’t find the install file…we have tried to search for FAW / SubLab in my Finder…and can’t find anything. We have also gone the manual route to search for it in the Library Folder / Application Support folder and we can’t seem to find where SubLab installs too.

If you can please help with this issue as well I would greatly appreciate it.

It seems that for some reason SubLab is not installing on your computer. First can you check double check if you don’t have the ‘/Library/Application Support/FAW/SubLab’ ? I’ve uploaded an image showing what I have here in finder when I navigate to the folder. If you don’t see this then something went wrong during installation.

Hi Gavin. I installed SubLab, regularly, to assume it installs into the location in my MacBook it chooses too…however when I check that file route you gave me…that folder doesn’t show up.

Do I maybe have a bad version of SubLab ?


Any word on sub lab crashing for some of us Gavin?

Hey @SunliteSoundz, I’m not sure what is happening there. Are you logged in as as a full administrator in macOS?