Circle 2.2.0 released, NKS support, new website and new products on the way


#1

Hey,

We’ve released version 2.2.0 today.

You can always find the latest version of Circle2 on our downloads page here.

This version includes support for NKS along with bug fixes. We’ve also updated the site, check out the new Patch Packs section, with more on the way soon.

We’ve updated the support page with articles on NKS, if you’re having any issues, just let us know here.

We’re also working on a new product, we’ll be getting in contact with you if your signed up to our beta forum once we’re ready for testing.

Onward and upward!

Gavin.


#2

hey Gav, where do i find the latest 2.20 installer? I’ve been going around in Circles (pun intended) for it


#3

Hey Damien,

You can always find the lastest installers here:

https://futureaudioworkshop.com/downloads


#4

Hey first of all congrats for the new website, very very cool!
Very excited about the new stuff you are working on, can’t wait to test it,

P.S.: there’s a dead link on your website: https://futureaudioworkshop.com/blog-articles (…sorry but I’m a beta tester inside :slight_smile: )


#5

Good find @Residente, we’ll fix it as soon as possible. We’re doing a soft launch so we can shake out these kind of issues before announcing the website fully, so much appreciate the help, its what we exactly want :slight_smile:

Glad you like the site, we’ve put a lot of effort into it, kind of the start of a new phase for FAW.


#7

@Gavin_FAW Good luck guys, you deserve all the best, IMO Circle2 is one of the best out there! :muscle:


#8

Hi There, my first post. I’m having the weirdest time trying to get NKS for Circle 2.2 RC1 to show up in Komplete Kontrol and was wondering if someone may have some ideas about what is going wrong. Maybe this is a bug report but it could also be a system permissions thing. After many hours of effort, I am unable to solve it.

I followed the instructions for installing Circle 2.2 RC1 (rescanning my VST directory) on both my laptop and my iMac (both running OSX 10.14 and both pretty new computers)

NKS works fine on my laptop, but not on my iMac. I noticed that the installer installed futureaudioworkshop folders to the NI resources area on my laptop, but not on my iMac. So I copied those from my laptop to my iMac and rescanned everything and it still doesn’t show up on my iMac.

I’ve done this several times, once removing everything circle or FAW with still no success. Even restarting my computer in between. Would love some suggestions on what I can check. I’m out of ideas…

best,

Greg K.


#9

Hey Greg,

I have a feeling it is a system permissions thing!

Are you logged in as an admin on the iMac, with full account privileges? Let me know, it might be an issue on our side but it could also be an easy fix for you by manually setting privileges.

We haven’t tested 10.14, so it might also be something to do with that.

Gavin


#10

Hi Gavin,

Thank you! Yes, I have full account privileges with my login and haven’t had any issues in the past or with other software. Happy to test out whatever could be useful for you!

Greg


#11

Greg, can you send me an email through to support@futureaudioworkshop.com and can go into more detail on your specific case.

Thanks,
Gavin.


#12

Hi again. Just wanted to let you know that I was able to get NKS to work in Mojave by copying the NI preset folder to the NI User Content area. I emailed you all about it.


#13

Just replied to you email Greg.


#14

Thanks, everybody! Hope you like 2.2.