Bought sublab yesterday, all versions crash immediately on latest fl studio


I bought sublab yesterday, it installs fine but immediately crashes fl studio opun being loaded.

It’s not one version that does this, all vst /vst3 versions do the same thing, so do 32 / 64 bit versions.

My fl studio is the latest FL 20 and is genuine, so is my win 10 Pro version.

Does anyone have any advise here?

Rather annoyed that this vst clearly has gone through zero testing and is advertised as “working with all daws”

I have messaged support but looking through this forum it seems maybe the best idea is just go for a refund straight away.

Hey DragonByte,

You’re coming in hot DragonByte!

Julia is working everyday on support and helping people there. Version 1.1.3 is out for over 6 months and we’d out of business a long time ago if it didn’t work. But that doesn’t take away from the fact it is crashing for you and we’re here to help!

Can you let me know exactly the version of both FL Studio and Windows 10 Pro you are running.
I’ll also need to know if you have tried launching it any other DAW. Do you have Ableton (even the free version) installed?

Thanks for the patience,


Apolagies for the annoyance but as you can imagine I was / am not impressed by buying a piece of software that doesn’t work in its default configuration with an advertised compatible product.

My FL studio version is 20.8.3 (Build 2304).
My Windows 10 pro version is 20H2 (OS build 19042.928)

No I do not have any other VST compatible software installed to test, but I can tell you it has worked once for me in FL studio.

The crash is fairly uniform and I can provide a video if needed, however the main take away is the UI usually responds to the first click, before the daw then freezes and eventually is either force closed by me or windows.

I believe the audio engine works fine, as when I place in a note before changing the channel to be sublab I can here the note play, but its then followed the crash mentioned above and happens the same way.

1 Like

No need for apologies @Dragonbyte!

A video would be useful if you can provide that. Also do you know what buffer size you’re using in FL Studio.

Usually I can tell by a video what might be up.


Hi Gavin,


this one is pretty typical, but normally when I click the sampler button there wont be a change.

My bugger size is usually maxed out at 2048. I have a pretty beasty PC but my I also quite often use the intire mixer rack so the buffer gets slammed. I dont at the moment but I also quite often use the tripple buffer option.

Many thanks for the help.

1 Like

That to me looks like there is something up with the openGL rendering of SubLab’s interface.

Also what size monitor are you using and what is your graphics card?

Thanks for the tip, I would suggest you are correct as I have just edited the settings.xml file changing the value of the opengl_disabled node to 1, and have been able to load sublab and then load another project and add it without issue.

It will likely take a little more testing though as this is what it did the last time it worked for me for a night.

I 've looked for a debug log/debug option for sublab but havn’t been able to see one, if there’s something I can provide let me know.

I dont know if its helpful, there was a similar issue seen with serum roughly 2 -3 version of FL 20 ago, however that seemed to be their end as I just rolled back the FL version, at the next release it was fixed and they had noted an issue, Apologies I don’t have an exact version number or release notes for you.

Monitors are 2 x 28inch Asus, both at 3840 x 2160, graphics card is a 3060, current driver is GeForce Game ready 466.27 (04/09/21)

If I can provide you any tests here, please let me know.

Many thanks for the help, I think you may have got me up and running! :blush:

1 Like

You’re way ahead of me!

That’s a serious setup, but I think there might have been some driver issue for the version of openGL, but you’ve already found the flag.

Would be great to have you on board beta testing for sure. I’ll add you to the list…

Thanks! I was really lucky I actually booked 15 mins off work to try and get one online and watched 4 websites go down in the process.

I think you are onto something here, I have managed to use FL with sublab on a couple of days this week with no issues.

Very happy to be on the beta, if I can test anything specific do let me know and thanks for the support.

Not gunu lie that VST packs some serious sub :smiling_imp:


I have FL Studio 20 myself, and SubLab loads up in FL Studio.I also have windows 10.It might be a little of a head ach,but you might have to factory reset your windows.Or it could be your registry inside windows 10…But SubLab works perfect for me.

Hello, I was just curious if you could possibly post a screen shot or a quick video of where you made this change? I tried to search for how to change the opengl node and i cant find anything…I keep having the same issue and its quite frustrating. Fl studio shifts into a 30 second lag the moment i open sublab.

Hi Tyson.

Sure :slight_smile:

In C:\Program Files\FAW\SubLab there is a file settings.xml.

Open it in notepad (or any code editor) and change the opengl_disabled node so that it has a value of 1:

<VALUE name="opengl_disabled" val="1"/>

That should be all you need, let me know how you get on :slight_smile:

1 Like

Did the fix @Dragonbyte post work for you @tysonblackmusic?


Thank you! For some odd reason since I posted I haven’t had any issues with sublab lol. But, I’m going to definitely keep this fix in the pocket! Thanks again!

I actually haven’t tried it yet. Sublab seems to be working fine now. It for sure seems to be a very specific scenario that causes the issue.

@tysonblackmusic, so you’re good to go Tyson?