Sublab XL Crashing FL Studio

SublabXL was working fine yesterday but today every time i open sublab XL fl studio crashes
im on windows 11 with the latest version of FL studio

ive tried reinstalling also tried the 1.0.1 beta same thing happens

Have you tried reinstalling FL studio? Rescan for vst’s and verify them. See what happens.

2 Likes

have you tried running FL Studio diagnostics test. goto > Help > diagnostics and run a few of the tests. The rendering test is useful to show you any obvious problems at a glance.

1 Like

Hey y’all thanks for you suggestions :pray:

Nate is back up and running - twas an issue with the graphics card.

2 Likes

I’m also having issues with SublabXL crashing and causing FL Studio 20 to hang and crash as well. I can load SublabXL into a new project and work within it for a while, but then at some point I can only see the SublabXL plugin outline. At that point, if I try to click on SublabXL, delete the channel, or even close FL Studio, it’ll hang and crash.

My workaround has been to rename the SublabXL dll file, reload the project without SublabXL existing, replace the .dll file, copy my scores over to the new instance and go from there. Eventually that instance does the same thing as well, but usually not until the next session.

Windows 10, Intel I9-10900K, RTX 2070 Super, 64GB RAM here…have never had a single issue with any plugins even when I’m running way more than I should be :slight_smile:

1 Like

Ok, so something is causing SubLab XL is freeze in FL Studio on your setup. I’ve a couple of questions, if you can answer them below it would be great :+1:

  1. Can you let me know if the interface is open when this happens?
  2. Are you using a factory preset from SubLab XL when this happens and if so, what is the name?
  3. Do you have any automation running or are you adjusting controls when this happens.

I’ll also do some tests there and see if I can recreate it :+1:

Thanks,
Gavin.

I never notice then moment that it freezes, I just eventually notice that it’s frozen…so yeah I suppose the interface is open every time. I’m just not sure if the interface is healthy in the session initially or if it freezes mid-session. I worked on it a bit but always got wrapped back up into the project before noticing the issue had returned. I’ll try to pay better attention the next time I’m in FL Studio, and see if I can come up with some steps to reproduce the issue :smiley:

The preset that I was trying to use for a while was UK 808, but I eventually considered that this maybe the issue and changed plugins. I could be wrong, but it -feels- like I get to use smooth 808s for longer than buzzy 808s, maybe distortion related? I’m tossing that idea out based merely on a hunch though, I haven’t A/B tested that theory.

I have a handful of automation clips in my project for some guitar tracks as well as another synth track or two…but no automations for SublabXL are in place as of yet. I couldn’t say if this happens when I’m adjusting any SublabXL controls either, for the reasons in the first paragraph of this response :smiley:

I’ve also rescanned and verified plugins as well as run diagnostics with no results of note.

I’ve gotta get some quality time with my pillow for now, and then I have a pretty hectic weekend away from my workstation until Sunday evening…so there’s no rush. When I get back though, I’ll get active on this to see if we can’t get to the root of the issue!

Ok, so for a start I think it would be good to disable openGL and make sure that it is not a graphics issue. To do this is pretty easy…

  1. Open the file c:/Program Files/FAW/SubLabXL/settings.xml in a text editor
  2. In the file you will see disableOpenGL=“false”…change this to “true”.
  3. Go back and use sublab xl with openGL disable for a while and let me know if you have the freeze again.
1 Like

Thanks for your additional response! I won’t be back at my workstation until Sunday evening, but as soon as I’m back I’ll give it a shot and let you know!