When I press a key there's a click, pop, and then NO sound... This plugin seems overrated and a waste of my $$$

Why is this happening? I’m running a 2018 Mac Mini, running thru Mojave 10.14.6 (for Battery 3’s sake), with an Intel Core i7.

There are some bass presets that only work on certain songs, but NOW there’s a high-pitched squeal, click and and then a POP, followed by absolutely silence, even if the session is in play.

I bought this plugin to work on EVERY song. Now it works on NO songs, and barely works on the songs I had it on, initially.

I had no issues after first purchase, and NOW it shuts down my entire session(s), EVERY time. I had to remove SubLab outta’ my music almost entirely.

My current version of SubLab is 1.1.4 (R418)

Please advise…

Hey @Chief

You’re coming in hot :fire:

First, make sure you have the latest update. Also, who did you buy from? If from us you can get the latest version installers directly from your user account under downloads. We’re on 1.1.6 now. If from Plugin Boutique, they have the new version also and should have sent it out by now.

In saying all that, there was an issue in 1.1.4 and we’ve fixed it. Please accept our apologies and that we are trying to better by releasing bug fixes and new versions :pray:

Hey Gavin,

I’ve tried to get the updated version from the website and ironically after following the instructions on how to, all I did was reduce the number of downloads I have…

I bought SubLab directly from FAW, which is what caused such confusion in the first place. If you wouldn’t mind providing a link that’d be great. Additionally, if I could get back that one download (since that also seems to be a convo) that’d be great!

I love the plugin, and I expect there to be “issues”, but so late in the game (?), it can be a bit frustrating…

Thank you for the reaching out,
I’ll await your response.


Just installed the 1.1.6. and my SubLab is STILL @ 1.1.4.

Hi Chief, I’m sending you a DM.

1 Like

Haven’t received anything…

Did you get the DM @Chief and are you now updated to 1.1.6?


Nah, I didn’t, yet.
I’m waiting on it.

Hi Chief, I sent you all the steps & reset your downloads