Unable to activate SubLab XL

I just bought SubLab XL directly from the website. I installed on my windows 11 computer and try to login to the plugin, and it keeps saying license not found. I have tried re setting my password and logging in through the stand alone sub lab app and that dose not work either. Please help me!


We’re looking into it right now.


Ok, so I’ve had a look and can activate ok…can you post a screen shot ( hiding any passwords or activation codes ) so I can see what is up?


It still wont work. I don’t have an authorization key, the instructions say to authorize sub lab xl by logging in through the vst.

Hey @CindyFlopper :wave:

I think I see what the issue is and fixed it. Could you please try again? :pray:

Take care,

Thanks Julia! Whatever you did worked somehow. Will I be able to authorize on 2 other computers as well?

Hey @CindyFlopper yup! You can have SubLab XL running on 3 computers at a time.

And, you can also deactivate machines like this: https://support.futureaudioworkshop.com/hc/en-us/articles/6192973784855-How-can-I-deactivate-my-computer-

Hi I have a the same issue but mine is on a reinstall on the same device please help as I need to fix a bassline in a project that has been singed & cant move forward :frowning:

I have the same issue! Bought it today, but cant activate or log in. Please fix?

Please try to activate again, it will work now :blush: