SubLab XL on Windows 11 Acip Pro 10 - NO SOUND AT ALL... HEEEELLLLPPPP!

Continuing the discussion from Trouble logging into SubLab in my DAW:

SubLab XL is not working. It installed and it loads up fine, but there is no sound whatsoever from any of the keys. I tried checking if it had glitched during the install and somehow not loaded in the samples and presets etc but all that is in good order. I have a brand new desktop and it’s awesomely powerful, so it definitely isn’t a hardware issue. I use Acid Pro 10, I have no issues with the original SubLab so long as I keep version 1.1.3 installed. If I update to any other version after 1.1.3 then it stops working (same issue, no sound at all). I did have issues getting Circle2 to work at first but then I got that to start working fine (my DAW just needed to be restarted after the activation process). My OS is Windows 11.

HEEEELLLLPPPP!!! My wife bought me SubLab XL as a gift and it’s not doing anything and I was really looking forward to using it because I’m pretty good at using the original SubLab but now I want to use my new gift from my wife to make even better music! Switching to a different DAW is not an option for me, I cannot afford to do that and plus I am autistic and fixated on Acid Pro because I’m so comfortable with it. I will eventually get a perpetual license for AVID Pro Tools Ultimate, but until I can afford that I am stuck with Acid Pro and it will be a long time before I can afford to get that version of Pro Tools. £2,500 obviously isn’t easy money for most folk.

Please support ACID PRO in the SubLab XL V1.0.3 update!

Hey @ogdubbofficial,

First, its great that your wife bought you a copy of SubLab XL and supports your music making :+1:

Also, nothing wrong with Acid Pro, afaik Burial used it to create what is regarded as the on of the best dubstep albums of all time.

Can you describe exactly what the problem is? Can you activate using the standalone?


Everythings seems to be in correct order all except simply the fact that when I hit a key on the MIDI inline editing keyboard (I don’t currently have my MIDI keyboard configured - long story kept short) it does absolutely nothing whatsoever. There is no sound, as I described, as if the preset and sample libraries are empty except they aren’t empty - I checked the folders in the “Programs - FAW” folder in my system. Additionally to no sound at all, the peak meters within the Acid Pro 10 DAW don’t register anything going on when I press a key. It’s just completely unresponsive. I already activated it - perhaps you can see this fact through your registration system and my account with you? So, the problem is not concerning activation, it’s simply the fact SubLab XL seems completely unresponsive within the DAW. Regarding the stand alone of SubLab XL, I currently cannot answer that question - please refer back to what I said about the MIDI keyboard where I’ve said as much as necessary, keeping a long story short for sake of conveying only what is relative to this issue.

And, thanks for your reply. My wife is supportive, yes, absolutely. She knows I am talented and skilled and make good music. She trusts the process. My IG name is the same as here and on YouTube if you wish to check out my social media (perhaps IG because my YouTube has undergone some extensive deleting campaign by me tidying up and will be back on point into the new callendar year approaching). Currently, it’s mostly just interesting content for consideration and a bunch of really funny videos I edited over on my IG, but I will soon be uploading video edits with clips of my instrumentals (mostly all London drill instrumentals).

I pointed out that I use Acid Pro 10 because it isn’t listed as one of the supported DAW’s on your website in the system requirements, and it’s obviously important you know this information in order to help resolve this issue - it’s a pretty big issue, clearly. I was really looking forward to using SubLab XL as I currently use the original SubLab to make all my 808 hits and sub-basslines. Thanks for that snippet of information regarding Acid Pro too, that’s interesting to know, though I don’t really like dubstep to be honest, but I can respect the art and the artists within the genre still. I really like Acid Pro, personally, and it really confuses me that it appears as though it is practically boycotted from ever being listed or talked about by anybody ever for some odd and undeclared reason, which is really pretty strange to me since Sony were the ones who came out with Acid Pro (I could be wrong, as I haven’t checked yet, but I suspect Magix is just a subsidiary of Sony anyway). I would have thought for this reason it would be oft used, listed and talked about, but it isn’t. Is this because all the other DAW companies pay royalties to the websites who list their DAW in system requirements specs for VSTi compatibility, all except for Sony/Magix who don’t? I have a sneaking suspicion this may be the case. However, I’d prefer if we concentrate on the issue I have with SubLab XL and I keep going off on a tangent hahahaha, sorry… back to the original script.

  • Btw, you guys should put up a link in everybody’s account for the original SubLab v1.1.3 because this same issue occurs for me as with SubLab XL if I try to use any version of SubLab after the v1.1.3 update, and I have read online that many others seem to be experiencing the same issues. In order to keep customers happy, in my humble opinion, it would greatly benefit you to include a link to SubLab v1.1.3 to every customer letting them know they will most likely find it in full working order if later updates don’t function (v1.1.3 works fine for me). An older version that functions properly is better than a newer one that does nothing at all. Personally I could never understand why you patched SubLab again and again since update v1.1.3 - it just doesn’t make sense. The old saying goes “Don’t try to fix what isn’t broken” and personally I think this applies directly to SubLab v1.1.3 for sure. Perhaps put a link to the very first version/s of SubLab XL before update 1.0.2 so we can find out if it does the same thing in the earlier versions of SubLab XL as it does with the original SubLab? This information should help your team with the next patch for the original SubLab so they might understand this compatibility issue and why v1.1.3 works fine but later versions don’t. They just need to do a comparative on the coding and see what the issue seems to be and then address it. Maybe there is a very similar coding issue with SubLab XL - for your consideration, I think I’ve been as fully descriptive as possible here.

Still awaiting a proper response, Gavin. And I need to state, I just upgraded to Acid Pro 11. When I loaded up SubLab XL within Acid Pro 11, it still doesn’t work. It does exactly the same thing: loads up fine, APPEARS to be in good working order, but when I hit a key nothing happens. The exact same problem as with Acid Pro 10. It looks like you may have to use this situation to initiate a line of communication with Magix and work on this together with them. You might develop a good relationship with them which could lead to working with them in the future, but the main focus is obvious to get SubLab fully operational within the Acid Pro DAW series.

I notice the main reply didn’t tag you into it for some reason. Sorry, my bad.

As stated in that big block of detail (you asked for detail hahah), SubLab v1.1.3 actually WORKS for me, but none of the other versions of SubLab after that will work. They all do exactly the same thing SubLab XL is doing for me, which is that it loads up and all looks fine and in good working order but then when I hit a hit or put a score into the MIDI there is no sound whatsoever.

I am certain this information will help you identify the issue very quickly and deal with it efficiently. My father is a very high profile software engineer, but I’m not sure he would be able to deal with music software simply because he lacks the sound engineer part of the equation. However, he seems pretty clear that this information will absolutely help you identify the issue very easily and rectify it. He says if v1.1.3 works then the solution is within the coding for that and he says it should be obvious what is missing or altered in the coding for the versions of SubLab that follow v1.1.3 and he says this should identify the solution for the SubLab XL coding too, since they seem to be very similar plugins, one apparently heavily built on the other.

I hope this helps. Damn, I feel like I’ve done volunteer work for you guys after all this and I paid to do it LMFAO… come on, guys, order, order, get to it, you have loyal but let down customers here (I am sure I am not the only one in the world with this issue who would love to see it fixed - I love SubLab, it is indispensible to me for what I do and I was really looking forward to getting to work with SubLab XL, and I have every pack for SubLab and I also have Circle2 and plan to get every pack for that too. Thankfully, Circle2 works).

  • I have Acid Pro 11 since yesterday, but the issue is across the board with Acid Pro and SubLab and SubLab XL. I have the same issue with it using Acid Pro 11 as with Acid Pro 10 just the other day before I upgraded.

@Julia I feel ignored. I’m a loyal customer too. I really need SubLab XL working. I’ve taken the time to document the issue in quite some detail as I expected would be required obviously, and I have also gone through some very useful information for you with a view to easily resolving this issue quickly; effectively, I have figured out a solution which will almost certainly resolve this issue. I’d have thought this is a great service to your team, regardless of the fact I am unable to provide you with the solution in the form of a coding script - if you read the solution you will know what I mean and I am sure you will see value in it. It’s a problem solving formula being applied to the issue to identify how the issue can be resolved easily, so it isn’t necessary for me to know coding to have provided you with at least that bare minimal information. The fact is, the issue is identified and the solution is also identified, now the coding expert is required to look at the things I have pointed out and write an update with the necessary script for both the original SubLab and for SubLab XL. As stated, I am only able to still use SubLab because by the will of The Almighty I bought SubLab when it was on v1.1.3 and still had the zip folder with that version in it by the time I figured out no update since that one is going to start working again on my system because it seems you think there is a problem with the coding script which actually allows it to run and have clearly altered or removed it from SubLab at some point after v1.1.3

The solution is pretty simple: identify which coding script associated with SubLab v1.1.3 has been altered or removed and has caused SubLab to not respond to the synth/softsynth keys being hit, then address the issue by redoing the coding script so that it works again. You may very well have to use Acid Pro 10 or Acid Pro 11 to aid you in identifying the issue too. You won’t know if the solution has been addressed otherwise. I’m pretty certain Magix will be more than happy to send a free copy of Acid Pro 10 or Acid Pro 11 to you so that you may address the issue easily and so you can assure your current and future plugins and updates will work with Acid Pro.

@Julia @Gavin_FAW I do apologize, I am not a christian and so I often forget the importance of this time of year for all those who are and who celebrate christmas culturally. Obviously, I’m het up about SubLab XL not working at all and I’m hoping to write music using it ASAP and so I’m in my own little bubble not thinking on a more wide basis contextually. I trust this issue will be resolved once you all have time to deal with it. That said, in the meantime, I hope you are all well and in good health and enjoying your break from work with your families. I look forward to your reply in around a week, I guess, when everybody is settled back into work.

Thankyou for your patience with me (and I promise this is not sarcasm lmao, I get it that I was being incosiderate in the context of the time of year because I am currently stuck in my own little bubble - I have my reasons, but I’m not going to pour my heart out here about all my problems in life nor am I about to reel off what could be taken as excuses for being inconsiderate, I own the fact I was being inconsiderate and I apologize).

Hey @ogdubbofficial,

We had to spend some time with family so a little slow in getting back to you.

I’m going to try acid pro today and see what is up.


@Gavin_FAW Of course, I’m very sorry, I do apologize. I don’t celebrate christmas so I am often completely oblivious to it all despite being surrounded by it everywhere and having family who do celebrate it. Please forgive me for my impatience.

On a more positive note, you may interpret my impatience as a passionate fervour and drive to use your SubLab XL plugin for my new music productions. I look forward to composing another drill beat once this issue has been resolved, so I do hope my in-depth explanation of what the issue is helps alongside my suggestion to look at what changed between the original SubLab v1.1.3 coding script and the subsequent versions that followed which do the same thing SubLab XL is doing - no sound whatsoever and nothing registering on the mixer peaks. I’m pretty confident this is where you will find the solution. For the meantime, whilst I’ve not been able to use SubLab XL, I’ve been making some minimal techno bangers using the original SubLab to design my kick layers.

I hope you all had a good time with your families and I look forward to this issue being resolved soon now you are safely back to work. Thanks!

I’ve become somewhat a hermit lately in my troglodyte den just concentrating on my music and I never watch TV haha, so I guess christmas stuff is not really that much in my face for it to be at the front of my mind that most people in the west are celebrating it right now to be fair on myself, though I was brought up celebrating it. Please do let me know if I was right that some of the coding script was removed or altered from SubLab v1.1.3 onwards because that will be your issue. SubLab has exactly the same problem from v.1.1.4 onwards - it opens fine and everything looks fine until I hit a key on the MIDI and there is no sound whatsoever and nothing registers on the mixer peaks at all.

Hi @Gavin_FAW I hope you’re well and in good health. I was in a panic over SubLab XL not working because I’m going through a lot at the moment and my music production is really helping me pull through it all in one piece. I was really looking forward to using SubLab XL to make some intense sub glides for some new drill beats I’m making only to find it does nothing. I hope with the detailed information I have provided together with a hazard guess at where you might find the solution, SubLab XL will be up and running on Acid Pro 11 in no time. You might also want to look into what’s up with the later versions of the original SubLab re: what went wrong after v1.1.3 whilst at it and do another update for the original SubLab too so v1.1.9 or whatever comes next has been repatched to work again. Please keep me informed about what’s going on. It would be nice to at least keep updated as to how long you think this might take; I presume it shouldn’t take long if I am onto something regarding the script coding for the original SubLab v1.1.3

@A.Shakur check this out… you may find my thread interesting… I think I have identified the issue in the coding script look, so there should be no excuse now and it should be fixed in no time…


@A.Shakur tap in over on the gram, exact same name as here… hit my DM

@Gavin_FAW you guys might need to hire my step father to sort this out. His services won’t come cheap, though, he’s one of the highest level software engineers you could likely ever find. The added annoying dynamic for me is the fact he could resolve this issue in no time if you hired his services. I’m still waiting to hear where we are at with this, I just saw and downloaded SubLab XL v1.0.3 in the hope that it would work now, but it still does absolutely bugger all whatsoever. No sound, as if the patch folders are all empty, but they aren’t. COME ON, GUYS, I’m getting a bad feeling after seeing the post by @A.Shakur this issue will remain ongoing despite the information I have provided because there was no acknowledgement of the information whatsoever in the very short response I got back a few days ago.

@Gavin_FAW I’m not saying I will, but I’m just saying it’s pretty TEMPTING to get somebody to break into your software and patch it up for me on a private level regardless of your t&c not to alter your software in any way… it seems I could be waiting 6 months or maybe never even see this resolved judging by all the hype online about SubLab XL not working PFFFFTTTT!!!

@Mikobuntu @sorg111 @VinceMom check out this thread. I think I have identified the issue with the coding script for SubLab XL re: it not doing anything at all upon loading for most people. There seems to be little excuse now for them to just crack on with fixing this issue. Re: installation crash, my SubLab XL crashed during activation the first time around and I had to restart the system and the DAW and try again. It opens and everything looks orderly until I hit a MIDI key and it does NOTHING! The patches folder isn’t empty, so there was no corruption in the file during downloading, it’s a coding script issue. This exact same issue started with the original SubLab after v1.1.3 so the answer should lay in this fact!



I just loaded up SubLab XL in Acid Pro 11 and can also can’t get SubLab XL to respond to midi notes.

I’m not a Acid Pro user and its my first time loading it since maybe 2003.

Have you been able to get an Arturia plug-ins to work in Acid?
The interface is loading and the presets also change and the animations work ( albeit some glitches with the blob ). This means that the audio engine is working fine, the problem is related to midi, in that the midi notes are not getting to SubLab XL, that is why it won’t sound.

I’ve done a bit of digging around and on the magix forum, there are other having what looks like a similar issue. With Vital, it seems that Acid Pro loads the VST3, which due to a bug in Acid, it won’t play midi notes. Its the same problem as SubLab XL. Have you tried loading the VST version of SubLab XL? I can’t seem to figure out how to do this and due to not being an acid user, it would be great if you can check and see if it works.

@Gavin_FAW With all due respect, I couldn’t give a sh*t about Vital because I don’t use it and that’s their issue. But I guess I know not to waste my money on it now.

I’m only concerned about SubLab XL working, Gavin. I’m sorry but that reply was inappropriate and a waste of my time except you inadvertantly gave me an unintentional heads up about not throwing my money away on Vital, basically. Well, thanks, I guess, but I’ll be happier if SubLab XL works so you should revert it back to the latest known version to work. Surely you have all your older versions of it so you can run it on Acid Pro 11 and see what the latest version that works is and revert back to that version until you can come up with a better coding script for the updates to follow. I will certainly be cautious with your “updates” from now on and will be keeping the latest working version so if your updates don’t work then at least I know I can revert back to the previous working version as with SubLab (original). Okay, so the solution is roll back (this problem is occuring with Pro Tools too) and send me the latest working version of SubLab XL