Sublab NKS Issues

So I recently had to do a fresh install of everything on my computer. Everything is working great except the NKS presets for Sublab. Sublab nor the presets appear in Maschine 2 or Komplete Kontrol. I can see the presets in Application Support > FAW > Sublab but there inside of Maschine or KK it doesn’t appear as a library in the preferences. The Sublab .plist is also in the correct place Library > Preferences but it still isn’t showing in Maschine or KK. Any ideas?

Hi @HorusAnd

Can you let me know what your macOS version is? Also have you tried installing extra sound packs or is this with the factory packs?


Hi @Gavin_FAW . I’m on macOS 10.14.6 Mojave. I have a couple sound packs installed. I’ve tried both with and without packs install. The odd thing is if i move the folder /Library/Application Support/FAW/SubLab/ThirdParty/NativeInstruments/Presets into another NKS instruments folder, let’s say Massive X, Users/Shared/Massive X, the Sublab pictures and presets, including expansions, show in Maschine and KK like they should. This isn’t ideal because if said Massive X was to update from native access, the presets would be overwritten. I’ve uninstalled and reinstalled the 1.1.2 directly from my FAW account and it hasn’t helped. I’ve reinstalled Maschine and KK multiple times by removing all folders in the root Library/Application Support/Native Instruments, the user ~/Library/Application Support/Native Instruments folder, the Users/Share/NI Resources folder and the .apps themselves in Applications. All of which hasn’t helped.

Any help is appreciated

Hi @HorusAnd

That is strange. The only thing I can think of is if there is some unusual paths stuff going on.

I think you have already do it, but if not, can you rescan the library for SubLab.

Also, can you do a screen print of your Maschine Library paths? This is what I have here and it works ok.

I don’t have a “Sublab Factory” listed under “Product”. I used to before reinstalling. Do you know how to add that?

Just following up, here’s a screen capture

Just sent the beta links @HorusAnd

Hey there, I can see sublab in the browser menu, I can pre-hear it, but when I load it, I don’t hear anything. It’s also not in my library in preferences. Any fixes?