Sublab and Sublab XL bugs


Are Sublab and Sublab XL still in active development?
Because both VSTs have the bug where phase isn’t reset to zero on new notes, the setting for that isn’t working… tested in Reaper 6.83 on Windows 11.

And there is a DC offset in Sublab to the synth/sample and sub caused by the filter mix function, it affects the synth / sample and sub. Turning both mix amount to 0% removes the DC offset.

I found these bugs in the latest release version and the beta posted at this community.


Hmm, ten days without a single reply? Not a good sign…

Hey @RPH,

In SubLab and XL, the phase will 100% recent to on new notes. Do you have the latest version?

On the DC offset, you can reduce this by turning down the resonance on the filter. I’ll also do some tests here and see if I can recreate the offset.

SubLab is very much still in development so don’t worry, we’ve just been working on some other topics past weeks hence slow reply on the forum. Support should always get back regardless.

Hi Gavin,

Thanks for the reply.

I retested Sublab and SublabXL:

Seems I was mistaken about SublabXL (version 1.04), the phase indeed resets on new notes, the problem there is the option to change it to “no reset” or “first note reset” doesn’t do anything here. Talking about x-sub only.

And the suboscillator in SublabXL always goes negative first, why is that?
Shouldn’t the sine go positive first? So from 0 to +1 instead of 0 to -1?
Translating it to a speaker-cone response means now the speaker goes back first then forward, you’d want the speaker-cone to go forward first then backward. Right?
(Request: It would be nice if we could choose how it starts.)

Sublab is version 1.1.9, it has this note setting: reset phase on new note = on
But in Reaper Psyscope pro shows me the phase is random with each note.
Again talking about x-sub only.



Ok, so firstly make sure you have the latest version.

Also, we have an “Optimize xSub phase” and “Phase Align Engines” setting. Can you try turning those on and seeing what happens on your scope :wink:

I found the options, after turning them on the initial bit of the waveform gets distorted.
It’s no longer a pure sine.

X-Sub won’t output a pure sine wave unless you turn down the harmonics.

Hi Gavin,

True, guess there was something wrong with my display. Could not reproduce it today.
As I already had the main bass harmonics turned down all the way when I mentioned it.

I wanted to make a video showcasing the stuff I found, but didn’t have the time this weekend.

For example:
Phase flipping is related to the volume ADSR.
Reset phase on new note = ON

  • Attack: 1.0ms
  • Decay: 1.9s
  • Sustain: 0%
  • Release: 241ms

…turn down the Decay or Release to stop the phase flipping with each note.

“Optimize xSub phase” and “Phase Align Engines” setting add latency to the x-sub, and quite a lot (in total about 16ms or 790samples).

When those options are OFF and you turn on the synth to Sine (0dB) and -12 tuning, then turn ON x-sub to 0dB: perfect phase cancellation.
Reason: x-sub sine goes from 0 to -1 first, the synth sine goes from 0 to +1 first.
Guess you added the optimize and phase align to correct for that behavior? Why not have the x-sub go from 0 to +1 as well?

““Optimize xSub phase” and “Phase Align Engines” setting add latency to the x-sub, and quite a lot (in total about 16ms or 790samples).”

The thing with optimising the phase of xSub, is that when you press a new note x-Sub will not reset its phase immediately as that would cause an abrupt click…instead it waits until the wave crosses zero and then waits again until the main synth waveform is out of phase by a preset amount and restarts from zero. This prevents a loud click in the sub-bass and also achieves the enhancement of the subs that fulfils what we describe in the blog post here:

There are two things at play here:

  1. We always want x-sub to not cause a click by resetting its phase immediately, as this is something that people requested we do. We therefore cross fade out x-Sub when a new note is played. We then reset the phase to zero, but we don’t output any sound until the x-sub crosses zero again and then we start output audio from x-Sub. The wait is related to how much out of phase we want to be in relation to the main synth oscillator.

new note → fade out x-sub → reset its phase → wait until we are out of phase by a per-determined amount with the main synth oscillator and then start from 0 phase again. We then have no clicks and also an optimal phase between xSub and the main oscillator as described in the blog post.

  1. For the phase, we have optimised it so that it doesn’t eat all the headroom. If you were to reset both x-Sub and synth waveforms to zero at the same time, you would have both waveforms in near perfect phase creating a peak and audio overload. Instead we delay x-sub so that it enhances the synth waveform. We get the same perceived loudness, but preserve headroom as per the technique in the blog post.

AFAIK no other synth on the market does this type of phase enhancement and click reduction for simple sine wave sub-bass.

hey gavin. i sent in a request over 2 weeks ago and never got a response. I need a 20$ credit to upgrade. every time i try to do it on the website, it takes me to my account and does nothing. My previous sublab purchae does not show up… Which is kind of strange, considering i used it last week on logic pro… And i am looking at the license key right now. My purchase does not exist on the website. the only thing it shows are the 3rd party packs i bought for 25$.

Hey Ethan,

I just responded to your support message, please keep an eye on your email inbox for that message :blush: