[Lasted Build] SubLab 1.1.4 (build date 06/05/20)

Hello Gavin, Im here to report that sub lab 1.1.4 is not working in Studio One 4.6.1
when loading a song that had the SL plugin on it from previous version 1.1.3 it somehow muted all the channel or tracks and after pressing the mute button on the track that had SL on it then the other tracks would turn on.
When i go to load a SL on a new track it will crash Studio One.

Hey @Beatzz,

Ok, that shouldn’t be happening! We’ve a new beta for testing and will hold this one back until I’ve had a chance to check out the issue you’re having in Studio One. If you can hang on until early next week we will be releasing it then. Thanks for the help and patience!

Gavin.

your welcome G.
I opened the song again and when i push play no sound once again until i mute the track that has SL on it, but when i put a new track with SL on it, it worked (no crash). I put midi in the Instrument track (that the new SL is on) and it worked played with it no problems so far

I’ve been having an issue using the VST3 iteration of SubLab in the MPC software (currently running MPC 2.8). It prompts for activation code, I enter code, I’m then able to get to the main GUI but no sound and I cannot change the presets. Each time I engage the plugin to bring it into view - it prompts for activation code.

Currently running SubLab 1.1.4, however, I’ve been experiencing this issue in prior versions.

Also, appears I’m unable to change the presets in standalone iteration of SubLab.3

Going to try installing the VST, VST 2 versions of SubLab, see if I have any luck - will keep you posted.

Windows 10 Pro ver 1909
Studio One 4.6.2
MPC 2.8

PS. Thanks for a really great and useful product! I’ve been able to import all my favorite 808’s/bass one-shots, categorize them with the tags, which makes it super easy to call up genre specific bass/808s for that quick workflow. Thank you!

Hey @PatrickH,

On the standalone, can you try setting a sound card from the “settings” menu up in the top left?

On MPC software, is it the exact same issue as in the previous version or has it changed?
On Studio One, does it work ok there?

Thanks for the help!
Gavin.

I’m sad to report that in the new beta 4 (Jun 5), the Sampler still has the same old problem of starting with a different phase every time. Even if the Blue release envelope gets to fully play out and there are gaps in between notes. Yes, the “Reset Phase” option is ON.

1 Like

@Baphometrix, let me check this out in Bitwig. I’ve done recording tests here in Ableton and it is resetting. Thanks for checking btw!

Gavin.

I really do test these things in Ableton too. Yes, it’s broken there too and has been since forever.

I got this behavior when I had an Audient iD14 (with their drivers). And I still get it with a MOTU M4 (with their drivers). I get it in Bitwig and Ableton. Both with a Push 2 controller. Bitwig uses an entirely different set of extension drivers to run the Push2 than Ableton, of course. And as you can see, two entirely different oscilloscopes show the same exact behavior.

And in all these same combinations of software and hardware, that same exact sample waveform starts perfectly in phase, with a positive upswing and no glitchy folds, in every Sampler I have (Ableton, Bitwig, or VST). If I drop that sample into synths that support sample playback, it’s fine in all of them. SubLab is literally the only synth I have that does this.

Hey @Baphometrix,

There is definitely some difference between what we are looking at. I’m not using an oscilloscope, instead rendering out the midi clip as audio test. I’ll first outline how I’m testing and then will put forward a couple of theories.

  1. I load up a sample in SubLab and then render out the midi clip as audio.

  2. I open the rendered audio file in Adobe Audition so I can inspect it. This is what I have:


So I don’t have those large obvious clicks that you have.

Couple of things you can try if you have time.

A) Can you load up ScandiDrum-Kick-Attack-Deep-1 and see what results you have.
B) Can you send me over the Moog Subsequent waveform you’re using so I can experiment with it here?
C) Can you confirm that you have the version 1.1.4 R354 dated 6/5/2020?
image
D) Can you load up ScandiDrum-Kick…and try rendering out a similar audio file and inspecting in a wave editor?

On my side, I’m doing all these tests on macOS, so I’m going to see what is happening on Windows. I have a couple of theories, one is that it there might be a value that is not initialized correctly on Windows and that is what is causing the problem. Rendering out the audio file in Live and checking the waveform in an editor and checking if the glitch is present will confirm that. If the glitch is present in the rendered audio file then it is something different between platforms. If the glitch is not present in the audio file, then it might be either something related to the playhead timing/midi inside SubLab or else maybe something related to the envelope triggered the scope in some weird way.

I’m getting repeated crashes trying to insert SubLab into Cakewalk by BandLab. Anyone else testing with Cakewalk (formerly SONAR)? It may be because it is not activated which I have seen as a problem before. I have not received an activation code yet. Anxious to get the activation code and determine what the problem is.

Hey @dgrace,

What OS platform are you on? I’ll have a look once I know this.

Gavin.

Windows 10 Pro 64 bit, Host 64 bit

image001.jpg

Gavin,

I’ll do all those steps tomorrow, but if you haven’t actually been testing this on a Windows machine, then I’m pretty certain it’s some difference between your Windows builds and your OSX builds.

Gavin, To clarify my request, I need to get an activation code from you. I got the email with the beta download. But no activation code. Got it installed, but am unable to activate and test.

@dgrace, can you private message me your email address and I’ll Julia to set you up.

Thanks,
Gavin.

@Baphometrix, We haven’t been testing this specifically, every time do a build we run through a set of tests, like loading presets, saving, parameter automation etc, most of which are automated at this point but it won’t catch something like this on Windows. Due to length of time it takes to do a build on Windows manually, we do all development on macOS. I’ve just set off a manual Windows build, I’ll check here as well and see if the issue is present. Thanks again for the help, I’ve spent a lot of time on this so obviously really want to get it fixed!

Okay Gavin, after testing some of the things you suggested, I’ve narrowed down the issue. It seems to revolve around Samples that are longer than roughly 8-10 wavecycles long.

The video explains all and demos the problem in detail.

1 Like

Here’s a link to that specific MoogSub37 sample for your testing pleasure. :slight_smile:

Tip for downloading the sample from Dropbox now that they’ve obfuscated that process slightly:

Ok @Baphometrix , let me have a check here using the same MoogSub37 sample…