Sublab XL - Sample sliders dont work like old version?


I am a long time user of Sublab, I have just moved to XL,

I am noticing that the Sample Start and End sliders and the loop Sliders are now not working for me?

Everytime i try to set the start and end markers they just jump from the start of the sample to the end, I can remedy this by holding inside the yellow arrows and then sliding, but then i lose the snap to zero crossing functionality,

Also when creating a loop I get the same problem, except when i try to drag from inside it just moves the entire loop?

Can i disable this? or what am i doing wrong, I never had this issue with the original sublab.

Hey @pjbridger,

What version are you running?


thanks for the reply - 1.0.2

Ok, I’ve sent you the latest 1.0.3 installers…there was an issue that crept into i1.0.2 but this was fixed in the latest version. Check the attached video for how it should work and let me know if you see the same…

yep it works now! Thank you :facepunch:

1 Like

Hi Again, So unfortunately it is still happening,

This is making XL very difficult to use for samples…

Ok, what version you using and also is there a specific situation where you can make it happen?

I have installed the 1.0.3 update that you sent me previously,

and it worked properly when I loaded it back up, but since then the same problem is back,

Basically whenever I try to move the sample start or end point, it will jump directly to the start or end of the sample,

It seems to me like it is trying to find the zero crossing point but not finding one so just jumping to the start or end,

its the same with loop points,

if you hold shift you can set the points but it doesn’t snap to zero crossings and becomes fiddly,

Hey @pjbridger could you please try to install the betas we posted :point_right: here?

That should be fixed in this beta version, I just tested it out here. Please do backup your SubLab XL program files before installing the beta just in case.