Sublab XL Note Velocity

Any update on the windows version with velocity? I’d love to give it a shot, as I’m having other issues with my current version as well. So far, I like what’s going on with SublabXL though! You guys are very responsive.

1 Like

We’ve got the beta ready to go, will upload it later today ( Friday )

1 Like

Awesome! I’m on mobile so forgive me if i missed it when searching, but how does one get access to the beta in these cases?

You can always find the latest beta posted in the pinned thread at the top of the forum here:

I can see it now and it looks so damn sexy on the KK49 display!!!

1 Like

Hello Gavin,

macOS Big Sur, (v11.7.1),
SubLab XL (v.1.02),

Cubase 12 v_12.0.50.387.
Pro Tools Ultimate v_2022.10.0.
Ableton Live 11 v_11.2.5.
Logic Pro v_10.7.4

The velocity do not work .

(In the setting tab, I did switched “on” the Note Velocity.)
Did I forget something ?
Thank You,

Hello Gavin.
Just as a note, I’m on the latest sublab XL beta (4) and note velocity does not seem to work anymore (just as the person above me noted).
Maybe fixed in 1.0.3?

1 Like

Good catch @cyberboycoolen! This was due to the change we made for the X-Sub glide control, it was crossing over in the velocity setting.

Just finalising a new 1.0.3 beta and will update the links when its is uploaded.


hey @Gavin_FAW , just upgraded to XL (live) due to not being able to get the velocity issue going on original Sublab. It still doesn’t seem to work. Am I missing something?

I also went in the settings and turn on note velocity, but still nothing.

I just downloaded XL (version 1.0.2.) and I’m on Logic Pro X 10.13.6

thank you

hey @Gavin_FAW , just following up on this last thread.

thank you,


Could you please try this beta?

:point_right: SubLab XL macOS 1.0.3 Beta3

Hy Julia,
No Velocity sensitivity with this version (OS Big Sur)
Tested on Cubase Pro 12 , Ableton Live 11.

hey Julia,

thanks, will do and keep you posted.

Hi Julia,

so just tried this a bunch of time and it still doesn’t work.

Activated the velocity option in the settings as well. I don’t know what I’m missing or what can be the issue. Can you please help me figure this out,

thank you

If the velocity settings is on and you have the latest version then it should work fine.
What version are you running?


Hello Gavin
The actual version is 1.0.3
The switch Note velocity is : ON

And they are no velocity response .

I’m using Live here also on with 1.0.3 on macOS 12.6

Are you using the VST, AU or VST? Also, what buffer size are you using?

OSX 11.7.2
I Trying with :
vst3 (Cubase 12 Pro)
AU (Ableton Live 11 Suite)
AAX (Pro Tools)
All Buffers 1024
In all case : no velocity response

Can you please help me with this???

@THISISSPECIALK and @kaufmanne

Can you both try the latest beta version here: