[Update] 1.1.8 update thread (latest beta 6 macOS 32/64, M1 & Win release 30/6/22)

Hey everyone,

Another SubLab beta is ready! We went on a deep dive an have worked out the clicks and pops! Thanks to everyone for their patience while we worked away on getting everything fixed :toolbox: :screwdriver:

Here are the links:

:point_right: macOS 1.1.8 Beta 6 M1

:point_right: macOS 1.1.8 Beta 6 32/64 (Install this version for AAX support)

:point_right: Windows 1.1.8 Beta 6

Please check out the beta and let us know if there’s any improvement with click and pops. Also let us know if you find any bugs :pray:

Fixes:

  1. There should now to no noticeable pops and clicks coming from the sampler.
  2. Sublab should now report the correct latency to your DAW. This issue was only present in the previous beta.

Thanks,
Julia

:star: Special Request: Please check the about page version number after running the installer. You can view the about page by clicking on the “sublab” logo in the top left of the plug-in window. You should see 1.1.8 as the build version.

1 Like

AAX64 file for SubLab says it invalid when launching ProTools Ultimate 2022.4 on Windows 10

1 Like

Hey Julia! Since this says “M1 only”, should those of us on Intel Macs wait for a new build?

Also I have a feature request I think would be really broadly useful:

Can you please add a random preset selector (like a dice or shuffle button), that when clicked, picks a preset from the whole list?

Would make it a lot more fun to get “surprises” and discover more subs, instead of navigating in alphabetical order all the time.

1 Like

Hey @TORLEY yes, please hang tight for the regular mac build!

That would be cool, it’s nice to have that option for sure. We’ll see what the devs say :slightly_smiling_face:

I can confirm that finally, this fix does fix the missing icon for standalone Windows.
thanks
rsp

1 Like

hi , when i open the link appear this message “the website may steal my personal or financial information” . can you send by mail the beta version installer ?

thanks

Hi SubLabers,
I confirm ’ 1. Fixed missing icon for standalone on Windows’ is definitely fixed.

I have noticed the following:

  • on Windows standalone version, the JUCE splash screen is displayed :smiley:
    see here → https://youtu.be/yx0EZbvhPVk
  • now I still get one case where I can experience some gliches in Ableton Live. It happens when the track is playing and I open the SubLab GUI. Anyway the glitch issue does no longer happen when I keep the plugin GUI closed.
    see here → https://youtu.be/9A2W5dDd5xg

Hope this helps :wink:

1 Like

The standalone icon is now displayed on my Windows desktop!

2 Likes

Keyboard midi trigger does not work at all now, because Sublab automatically closes when I press any key on my labtop keyboard.

:point_up_2: New installer links are at the top

I have the same problem

just installed the beta, it does not fix the clicks and pops. seriously what’s going on? everyother soft synth or sampler i’ve used doesn’t have this issue, its been years with no resolution.

@dallasrose…do you want to take an audio recording or do a video of the clicks and pops? Also can you let me know what OS you are running?

Thanks,
Gavin.

Mac OS Monterey 12.0.1. Yes I can make a recording, but I see a lot of complaints here, clearly there’s just something wrong with it, and has been for a long time.

Hey guys

Does 1.1.8 work with logic X in rosetta mode? Running macos 12.3 but some of my go to plugs don’t run natively yet.

I’m also ready for the era of pops and clicks to end :confused:

1 Like

any progress? i have to export a one shot out of sub lab and put it into some other sampler to use it. it’s totally insane please fix it

Hey @everyone,

We’ve uploaded a new beta that has a fix for the pops and clicks!

Check it out at the links at the topic of the post, which have all been updated.

Hey @dbmagic yes! Should work no problem.

Check out the beta we just posted (links are updated at the top). I think we’ve gotten to the bottom of the pops and clicks :pray:

Hey @dallasrose please try the installer links we just posted now - the updated links are at the top :point_up_2:

1 Like